Error en calculo de impuestos, en vez de 6,5% aplica un 65%

Cuestiones sobre cómo utilizar Dolibarr, ayudas sobre las funcionalidades o cualquier cuestión que no está relacionada con un error para usuarios de latino américa.

Error en calculo de impuestos, en vez de 6,5% aplica un 65%

Notapor AGRM » Vie, 01/03/2019, 22:12

Buenas tardes,

tengo un problema al calcular los impuestos en facturas

Durante 2018, que tenía una tasa de 7% no había tenido ningún problema, pero este año a cambiado a 6,5%
Desde que modifiqué el valor en el diccionario en el momento de hacer el calculo a veces le aplica un 6,5% y otras veces un 65% dependiendo de si es servicio o producto, o si estoy introduciendo un concepto nuevo en la factura o haciendo una modificación de uno ya existente, también varía entre presupuestos y facturas.

Es decir ocurre, por ejemplo, al añadir un producto en una factura. O también al MODIFICAR un servicio (la primera vez que añades un servicio se pone bien a 6,5% pero si modificas algo y grabas se pone a 65%)

¿Alguien sabe que puede ser?
AGRM
Novato
 
Mensajes: 8
Registrado: Mar, 09/01/2018, 14:04

Re: Error en calculo de impuestos, en vez de 6,5% aplica un

Notapor edd_ts » Mar, 05/03/2019, 00:47

Creo que es un error de traducción, intenta poner punto decimal(6.5) en vez de coma(6,5) para confirmar si este es tu error. Si es así seguramente tendrás que revisar las traducciones en Home->Setup->Translation->Search a translation key or string->SeparatorDecimal actualmente debe ser "." y lo cambias por ",".

O revisa el idioma que tienes por defecto para tu empresa/usuario, no se en que país te encuentres pero posiblemente en las configuraciones de tu empresa registraste un Pais/Idioma en el que por defecto tienen punto decimal en lugar de coma decimal, o al entrar con otro usuario sin configurar el mismo idioma por defecto, tienes diferencias por esta cuestión.

Comenta si con esto lo puedes resolver.

Saludos.
edd_ts
Novato
 
Mensajes: 8
Registrado: Vie, 27/04/2018, 21:16

Re: Error en calculo de impuestos, en vez de 6,5% aplica un

Notapor AGRM » Mié, 06/03/2019, 12:28

edd_ts escribió:Creo que es un error de traducción, intenta poner punto decimal(6.5) en vez de coma(6,5) para confirmar si este es tu error. Si es así seguramente tendrás que revisar las traducciones en Home->Setup->Translation->Search a translation key or string->SeparatorDecimal actualmente debe ser "." y lo cambias por ",".

O revisa el idioma que tienes por defecto para tu empresa/usuario, no se en que país te encuentres pero posiblemente en las configuraciones de tu empresa registraste un Pais/Idioma en el que por defecto tienen punto decimal en lugar de coma decimal, o al entrar con otro usuario sin configurar el mismo idioma por defecto, tienes diferencias por esta cuestión.

Comenta si con esto lo puedes resolver.

Saludos.


El país que lo tenemos es España, pero funcionamos en islas Canarias, donde en vez de IVA(21%) tenemos IGIC(actualmente 6,5%)

Al ir al apartado que me comentas " Home->Setup->Translation->Search a translation key or string->SeparatorDecimal actualmente debe ser "." y lo cambias por ",". " No veo como cambiar el "." por la "," como tu me dices.

Gracias por la ayuda.
Adjuntos
dolidecimal.PNG
dolidecimal.PNG (18.62 KiB) Visto 756 veces
AGRM
Novato
 
Mensajes: 8
Registrado: Mar, 09/01/2018, 14:04

Re: Error en calculo de impuestos en vez de 65 aplica un 65

Notapor AGRM » Mar, 19/03/2019, 12:43

Edwardswits escribió:Yo lo calculo y me sale bien, como el ejemplo que me pones.

?Me puedes indicar el ejercicio que es o que son?


Expongo 2 casos como ejemplo del error:
1.- Creo un PRESUPUESTO nuevo.
Añado 1PRODUCTO de valor 10€ con igic 6,5% y se le aplica INCORRECTAMENTE un 65% y queda con valor de 16,50€.

2.- Creo una FACTURA nueva.
Añado 1SERVICIO de valor 10€ con igic 6,5% y se aplica CORRECTAMENTE un 6,5%.
Ahora si modifico el SERVICIO y grabo los cambios, el impuesto varía y se aplica INCORRECTAMENTE un 65%.

¿Alguien sabe por dónde puede venir el error?
Gracias
Adjuntos
DolibarError1.png
DolibarError1.png (35.92 KiB) Visto 673 veces
AGRM
Novato
 
Mensajes: 8
Registrado: Mar, 09/01/2018, 14:04

Re: Error en calculo de impuestos, en vez de 6,5% aplica un

Notapor echeide » Vie, 17/05/2019, 23:04

Buenas noches,

Han podido obtener solución al error a mi me pasa justamente lo mismo. Y en el fichero de traducción esta correctamente por lo que creo que tiene que ser más cuando se calcula el precio con el impuesto.

Pueden ayudarme a solucionar el error.

Saludos cordiales
echeide
Novato
 
Mensajes: 2
Registrado: Vie, 17/05/2019, 23:01

Re: Error en calculo de impuestos, en vez de 6,5% aplica un

Notapor echeide » Vie, 17/05/2019, 23:10

Buenas noches,

Han podido solucionar el error, me pasa justamente lo mismo. Cuando inserto un nuevo producto o servicio lo introduce correctamente con el 6,5 % pero si edito esa línea automáticamente te pone 65% de impuesto.

He mirado las traducciones y los separadores de decimales y los miles están correctamente como se ve en el fichero adjunto.

Pueden ayudarme a solucionar el problema?

Saludos cordiales
Adjuntos
separador_decimal.png
separador_decimal.png (90.91 KiB) Visto 391 veces
echeide
Novato
 
Mensajes: 2
Registrado: Vie, 17/05/2019, 23:01

Re: Error en calculo de impuestos, en vez de 6,5% aplica un

Notapor AGRM » Jue, 11/07/2019, 10:24

Elevo el tema,

seguimos sin encontrar donde puede estar el fallo.
¿Alguien ha encontrado solución?
AGRM
Novato
 
Mensajes: 8
Registrado: Mar, 09/01/2018, 14:04

Re: Error en calculo de impuestos, en vez de 6,5% aplica un

Notapor ferran » Jue, 11/07/2019, 15:59

Hola,

prueba a quitarle el código a la tasa de IVA. Lo que sale entre paréntesis 'igic6'.

De todos modos, creo que en las últimas versiones de Dolibarr está resuelto.

Un saludo.
2byte.es Preferred Partner de Dolibarr.
¿Quieres soporte profesional? Contacta con nosotros
Avatar de Usuario
ferran
Almirante
 
Mensajes: 415
Registrado: Vie, 18/01/2013, 16:31
Ubicación: Gandia, Valencia


Volver a ¿Como?

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 0 invitados